[Announcement] End of Support for Devices with iOS 8 and Lower

[Announcement] End of Support for Devices with iOS 8 and Lower

Unfortunately, with the upcoming update planned in May, we’re forced to discontinue the support for iOS devices with versions lower than 8.

Effective date: May 9, 2019, effective upon maintenance break

Affected devices/versions: iOS 8 or lower / iPhone 4 or older models (excluding iPhone 4s)

If you’re playing Mad Rocket: Fog of War on an iOS version of 8 or lower, you won’t be able to play the game unless you update your iOS to the latest version.

If you’re planning on purchasing a new device and want to keep your game progress, please make sure to link your account.

  • How to save your game progress: [LINK]
  • How to transfer your game onto another device: [LINK]
  • Find the software version on your iOS device: [LINK]
  • How to update your iOS device to the latest version: [LINK]

%d bloggers like this: